Defecto #773

Fallo en Software & Updates, falta template para Huayra/sud

Añadido por Pedro Boliche hace alrededor de 2 años. Actualizado hace más de 1 año.

Estado:CerradoFecha de inicio:14-04-2015
Prioridad:NormalFecha fin:
Asignado a:Desarrollo% Realizado:

0%

Categoría:Configuración
Versión prevista:Huayra 3.2
Visto en:3.0

Descripción

No levanta "Software & Updates". En la terminal "software-properties-gtk" termina con :
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for Huayra/sud

Este fallo repercute en: Synaptic->Configuración->Repositorios se levanta un dialogo informando que "la información de los repositorios a cambiado. hacer clic en el botón recarga para que los cambios surtan efecto". Recargando no se informa nada y al reintentar ...->Repositorios aparece el mismo dialogo.

Se sale adelante en 3.0/i386 agregando los archivos Huayra.info y Huayra.mirrors en el dir /usr/share/python-apt/templates/ con los contenidos siguientes

Huayra.mirrors :

#LOC:AR
http://repo.huayra.conectarigualdad.gob.ar/huayra/

Huayra.info:

Suite: sud
RepositoryType: deb
BaseURI: http://repo.huayra.conectarigualdad.gob.ar/huayra/
MatchURI: http://repo.huayra.conectarigualdad.gob.ar/huayra/
MirrorsFile: Huayra.mirrors
Description: Huayra 3 'sud'
Component: main
CompDescription: Soportado oficialmente.
Component: contrib
CompDescription: Paquetes compatibles con las DFSG con dependencias No Libres.
Component: non-free
CompDescription: Paquetes No compatibles con DFSG.

Suite: sud-updates
RepositoryType: deb
BaseURI: http://repo.huayra.conectarigualdad.gob.ar/huayra/
MirrorsFile: Huayra.mirrors
Description: Huayra 3 'sud' Actualizaciones
Component: main
CompDescription: Soportado oficialmente.
Component: contrib
CompDescription: Paquetes compatibles con las DFSG con dependencias No Libres.
Component: non-free
CompDescription: Paquetes No compatibles con DFSG.

Abrazo.

Huayra.info (838 Bytes) Pedro Boliche, 14-04-2015 22:54

Huayra.mirrors (59 Bytes) Pedro Boliche, 14-04-2015 22:55

Histórico

#1 Actualizado por Fernando Toledo hace más de 1 año

  • Categoría establecido a Configuración
  • Asignado a establecido a Desarrollo
  • Versión prevista establecido a Huayra 3.2

#2 Actualizado por Fernando Toledo hace más de 1 año

Tenemos parcheado python-apt en el repo de Huayra. SEgurametne podemos agregar estos archivos al parche.

para que aparezcan como updates las suites tienen que aparecer de esta forma:

Suite: sud
RepositoryType: deb
BaseURI: http://repo.huayra.conectarigualdad.gob.ar/huayra/
MatchURI: http://repo.huayra.conectarigualdad.gob.ar/huayra/
MirrorsFile: Huayra.mirrors
Description: Huayra 3 'sud'
Component: main
CompDescription: Soportado oficialmente.
Component: contrib
CompDescription: Paquetes compatibles con las DFSG con dependencias No Libres.
Component: non-free
CompDescription: Paquetes No compatibles con DFSG.

Suite: sud-updates
RepositoryType: deb
BaseURI: http://repo.huayra.conectarigualdad.gob.ar/huayra/
MirrorsFile: Huayra.mirrors
Description: Huayra 3 'sud' Actualizaciones
ParentSuite: sud

Suite: sud-proposed
RepositoryType: deb
BaseURI: http://repo.huayra.conectarigualdad.gob.ar/huayra/
MirrorsFile: Huayra.mirrors
Description: Huayra 3 'sud' propuestos para actualizar
ParentSuite: sud

#3 Actualizado por Fernando Toledo hace más de 1 año

  • Estado cambiado Nuevo por Resuelto

corregido en python-apt-0.9.3.12huayra2

#4 Actualizado por Fernando Toledo hace más de 1 año

  • Estado cambiado Resuelto por Cerrado

Exportar a: Atom PDF